Initiale IOS Konfiguration

Kennt ihr das auch? Ihr erstellt eine initiale IOS Konfig, packt die per TFTP ins NVRAM als startup-config, rebootet und dann… NIX.

Also: Hinlaufen und checken:

  • Passwort auf der Konsole passt schonmal
  • Router-Name ist auch OK, Konfig ist wohl angekommen
  • Hm… Interfaces sind auch alle da, aber im shutdown… „Warum? Ich hatte doch no shutdown in die Konfiguration eingebaut…“

Das passiert gerne mit Sub-Interfaces, alles ist logisch konfiguriert, aber die Physik bleibt down. Nachdem das ganze einmal von Hand konfiguriert wurde und dann von IOS nochmal selber gespeichert wurde ist dann alles in Butter. Aber warum? Und warum hole ich bei so was immer so weit aus? Naja, das eine hat mit dem IOS Parser zu tun, und das andere mit Tipp-Geräusch meiner Tastatur. Ich mag die 🙂

So, letzteres tut aber jetzt nix zur Sache, aber der IOS-Parser: IOS checkt wenn es keine „sinnvolle“ Konfiguration fuer ein Interface gibt und ignoriert dieses dann beim booten. Das erkennt man immer daran das nach dem booten immer noch die Zeile SETUP: new interface FastEthernetX/Y placed in "shutdown" state erscheint.

„Wie kann man das jetzt verhindern?“, und vor allem: „Warum kommt er nicht endlich mal zu Punkt?“ mögt ihr denken 😉 Ganz einfach: Gebt IOS einfach „sinnvolle Konfigurationen“. Jahahaha… Nein, ehrlich: Um ein Physikalisches Subinterface beim booten mit einer initial-config zu aktivieren reicht das hier im Interface:

interface FastEthernet 0/0
 speed 100
 duplex full
 no shutdown
 !---Bis hierhin war alles „unwichtig“, jetzt kommt der Trick:
 ip address 1.1.1.1 255.255.255.0
 no ip address
 !
 interface FastEthernet0/0.123
 encapsulation dotq1 123
 ip address 10.1.123.1 255.255.255.0

Vorher

R1#show startup-config | section interface FastEthernet 0/0
interface FastEthernet 0/0
 speed 100
 duplex full
 no shutdown
 interface FastEthernet 0/0.123
 encapsulation dot1q 123
 ip address 10.1.123.1 255.255.255.0
R1# show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet0/0.123        10.1.123.1      YES manual administratively down down

Nachher

R1# show startup-config | section interface Fa.*_0/0
interface FastEthernet 0/0
 speed 100
 duplex full
 no shutdown
 ip address 1.1.1.1 255.255.255.0
 no ip address
interface FastEthernet 0/0.123
 encapsulation dot1q 123
 ip address 10.1.123.1 255.255.255.0
R1# show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  up                    up
FastEthernet0/0.123        10.1.123.1      YES manual up                    up

Wie man sieht taucht die IP nie mehr auf dem Router selber auf, weil die beim boote konfiguriert und direkt wieder gelöscht wird. Weil aber eine IP ein doch einigermaßen wichtige Information für IOS darstellt geht das Interface hoch, und die Sub-Interface funktionieren direkt. IOS checkt aber beim booten nicht ob es auch wieder die Informationen wieder weg konfiguriert bekommt, ergo: Interface bleibt oben. Gleiches Prinzip übrigens bei Frame-Relay und allem was sonst noch mit Sub-Interfaces arbeitet.

Morgen gibt es noch ein Special zu OSPF, BGP und Tag-Werten. Auch sehr witzig, manchmal sind RFCs gar nicht schlecht… Aber mehr dazu morgen 🙂

-schommski